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MapInfo Professional 7.0 Features and Enhancements 

Arrow Key Enhancements
Use the arrow keys to move a selected object in an editable layer in a map or layout 
window.

• Press the up, down, left and right arrow keys to move the objects 1 screen 
pixel in the corresponding direction.  

• Press the Shift key when selecting the Arrow key to move the object 10 pixels.

Controlling the Location of Application Data Files 
During Installation
By default, the setup program for MapInfo Professional installs application data files 
to locations that make sense for the typical user.  After installing MapInfo 
Professional, the user is free to move one or more of the application data files to 
another predefined location and MapInfo will find that file.  For example, the 
administrator of a machine might move mapinfow.pen from the per user area (its 
default location) into the install directory so all users on that machine will share the 
same set of pens.  

For IT persons responsible for a large number of MapInfo installs it is not practical to 
manually move application data files to realize the desired configuration.  To solve 
this problem we have developed a solution that allows IT persons to specify the 
location of application data files by modifying a setting file, call MODE.INI, prior to 
installing MapInfo Professional.  The exact steps are:

1. Rename the MODE.INO file (found in the root directory of the installer) to 
MODE.INI.

2. Open MODE.INI into any text editor.

3. Edit MODE.INI, modifying the code of the application data file/group whose 
location you wish to change.

4. Install MapInfo Professional.

The following is a list of predefined locations for application data files supported by 
MapInfo Professional, and the corresponding numeric code to be used in MODE.INI.
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The following is a list of application data files/groups and their default location: 

Coordinate Extractor Tool
The enhanced version of the Coordinate Extractor Tool allows you to extract 
coordinates in any projection listed in the .prj file.  

In the Coordinate Extractor dialog, choose:

Code Description Location

1 per user, roaming <Current User>\Application Data

2 per user, not roaming <Current User>\Local 
Settings\Application Data

3 per machine <All Users>\Application Data

4 program directory <Install Dir>

Filename Default Location

mapinfow.clr per user, roaming

mapinfow.pen per user, roaming

mapinfow.fnt per user, roaming

mapinfow.abb program directory

mapinfow.prj program directory

mapinfow.mnu program directory

custsymb per user, roaming

thmtmplt per user, roaming

graphsupport per machine
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• Use Table’s Native Projection

or

• Use Non-Native Projection: click the Select Projection button to display 
projection options.

Creating a New Table from an Existing Table 
The Create New Table command now allows you to create a new table based on an 
existing table.

To create a new table from an existing table:
1. Choose File > New Table.  The New Table dialog displays.

2. Choose Open New Mapper.
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3. Choose Using Table:  Select a table from the drop-down list. The New Table 
Structure dialog displays containing the information from the selected table.

4. Select the information to be included in the new table.

5. Choose Create. The Create New Table dialog displays.

6. Specify a location for the new table. 

Creating a New Table Using the Combine Objects 
Feature
 The Combine Objects Using Column dialog now offers the option of creating a  new 
table for the newly combined objects. 
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Combine Column using Column dialog

1. In the Store results in Table drop-down, choose New. The File > New dialog 
displays.

2. Complete the New Table dialog, the appropriate Data Aggregation dialog 
displays.

If the same table is selected as the Combine Objects from Table and store results in 

Table, this Data Aggregation dialog displays:

Destination

A list of column names appears in the upper half of the dialog. To select one column 
name from the list, click on that column name. To select a group of column names, 
shift-click. To select or de-select one column at a time, control-click.

Once you have selected one or more columns, click on an option in the lower half of 
the dialog to apply that option to all selected columns. If you want to choose the Sum 
or Average method, make sure that all of the selected columns are numeric columns. 
If any of the selected columns are not numeric, the Sum and Average options are 
grayed, because Sum and Average cannot be applied to non-numeric columns.

Aggregate Method

Blank 

Choose Blank to store blank values in the selected column(s).

To store blank values in all columns, check the No Data checkbox. Only choose the 

Blank option when you want to blank out individual columns. The Blank option is 
available only if you did not specify a map editing target. 
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Value 

The Value option is a radio button with an associated text edit field.

Choose the Value option to store the value displayed in the edit field in the new row. 
Enter an appropriate value in the field. 

Sum

Choose the Sum option to calculate a sum based on the column values from all the 
objects to be combined. MapInfo stores the sum in a column of the new row. The Sum 
option is available only if you have selected a numeric column or columns.

If you have specified a map editing target, and if the editing target is in a different 
table than the currently selected object(s), the Sum option adds numeric values from 
both tables, and stores the sum in a column of the target object. 

To add values from two tables: 
1. Choose a column name from the list in the upper half of the dialog. This 

choice designates which of the target object's columns will hold the sum 
value. 

2. Choose a column name other than "none" from the drop-down list in the 
lower right part of the dialog. This drop-down list contains all numeric 
columns from the selected objects. 

3. Choose the Sum option. MapInfo calculates the sum of values of the selected 
objects' numeric column (the column you chose in step 2), then adds the 
target object's numeric column (the column you chose in step 1), and stores 
the grand total in the target object's numeric column. 

Average

Choose the Average option to calculate the average of the column values for all the 
objects to be combined. MapInfo stores the average in the new row.

If you choose the Average option, and you do not choose a Weight By column, 
MapInfo calculates simple averages: MapInfo sums the data values from all the 
objects to be combined, and divides the sum by the number of objects to be 
combined. If you choose a Weight By column, MapInfo calculates weighted averages. 
See Weight By, below.

The Average option is available if you have selected only numeric columns. 
Furthermore, if you have specified a map editing target, and if the editing target is in 
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a different table than the currently selected object(s), the Average option only becomes 
available when you choose a column name other than "none" in the columns drop-
down list. 

Weight By

Choose a column from the Weight By drop-down list to perform weighted averaging. 
With weighted averaging, MapInfo adjusts the calculation of averages so that the 
values from each selected object are weighted more or less heavily. Thus, the Weight 
By column gives some of the selected objects more impact, or "weight" than others. 

For example, your table may contain two numeric columns: a median income column, 
med_inc, and a net population column, net_pop. When you combine two regions in 
this table, you probably want to use the Average option to calculate the average of the 
median income values. Thus, if one region has a med_inc value of $30,000, and 
another region has a med_inc value of $36,000, and you combine the two regions, the 
resultant region might have a med_inc value of $33,000. 

However, if one of the regions has a larger population than the other region, you 
probably want the larger region's med_inc value to be weighted more heavily when 
MapInfo calculates the average median income. In the Data Aggregation dialog, 
perform these steps: 

1. Choose the med_inc column from the list in the upper part of the dialog. 

2. Choose Average. MapInfo averages the med_inc values when combining 
objects. 

3. Choose the net_pop column from the Weight By drop-down list. MapInfo 
weights the average median income calculations. Thus, objects with large 
net_pop values affect the median income averaging more than objects with 
small net_pop values. 

4. If you are combining closed objects, the Weight By drop-down list contains a 
special option: Area. If you choose Area from the Weight By drop-down list, 
MapInfo weights the average calculations according to the relative 
geographic areas of the regions to be combined. 

If you are combining linear objects, do not choose Area as the Weight By option. 
Linear objects have no width, thus they have no area. 

To choose standard (non-weighted) averaging, choose "none" from the Weight By 
drop-down list. 
7 Beta Documentation



  MapInfo Professional 7.0 Features and Enhancements
The Weight By control becomes available when you select the Average option. The 
Weight By control is not available if the target object is in a different table than the 
selected objects. 

No Data 

Use of the No Data checkbox depends on whether you have specified a map editing 
target: 

If you have not specified a target, check the No Data checkbox to store blank values 
in all columns of the new row. If you have specified a target, check No Data to leave 
all column values of the target object unchanged. 

Creating a Theme Using Individual Categories from a 
Theme Template
The following checkbox has been added to the Create Thematic Map - Step 1 of 3 
dialog:

Use Individual Categories 

Enabled only if the selected individual value template contains the names of the 
individual categories and their associated styles. If checked, the theme is created 
using the individual categories from the template. Any names of categories found in 
your data that are also found in the template, will receive the individual category 
style for the name from the template. If unchecked, the template is applied to the 
theme without regard for the individual category names.

Data Aggregation for Buffering
In MapInfo Professional 7.0, Data Aggregation is available for buffering. When 
creating a buffer, the table of buffers can be joined to data associated with the original 
objects buffered.
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To use data aggregation when buffering:
1. Choose Objects > Buffer. The Buffer Objects dialog displays.

2. Complete the dialog. If the open file is a Browse window, the Next button 
displays: choose Next and complete the Aggregation Method dialog. If the 
open file is a Map window, choose OK.
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3. The Data Aggregation dialog displays. The specific type of Data Aggregation 
dialog that displays depends on whether you chose to create one buffer for 
each object or one buffer for all objects.

Aggregation Method dialog
Blank Choose Blank to store blank values in the selected column(s).

To store blank values in all columns, check the No Data 
checkbox. Only choose the Blank option when you want to 
blank out individual columns. The Blank option is available 
only if you did not specify a map editing target.

Value  The Value option is a radio button with an associated 
text edit field.
Choose the Value option to store the value displayed in the edit 
field in the new row. Enter an appropriate value in the field. 

Sum  Choose the Sum option to calculate a sum based on the 
column values from all the objects to be combined. 
MapInfo stores the sum in a column of the new row. The 
Sum option is available only if you have selected a 
numeric column or columns. If you have specified a map 
editing target, and if the editing target is in a different 
table than the currently selected object(s), the Sum 
option adds numeric values from both tables, and stores 
the sum in a column of the target object.
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To add values from two tables: 
1. Choose a column name from the list in the upper half of the dialog. This 

choice designates which of the target object's columns will hold the sum 
value. 

2. Choose a column name other than "none" from the drop-down list in the 
lower right part of the dialog. This drop-down list contains all numeric 
columns from the selected objects. 

3. Choose the Sum option. MapInfo calculates the sum of values of the selected 
objects' numeric column (the column you chose in step 2), then adds the 
target object's numeric column (the column you chose in step 1), and stores 
the grand total in the target object's numeric column. 

Average
Choose the Average option to calculate the average of the column values for all the 
objects to be combined. MapInfo stores the average in the new row.

If you choose the Average option, and you do not choose a Weight By column, 
MapInfo calculates simple averages: MapInfo sums the data values from all the 
objects to be combined, and divides the sum by the number of objects to be combined. 
If you choose a Weight By column, MapInfo calculates weighted averages. See Weight 
By, below.

The Average option is available if you have selected only numeric columns. 
Furthermore, if you have specified a map editing target, and if the editing target is in 
a different table than the currently selected object(s), the Average option only becomes 
available when you choose a column name other than "none" in the columns drop-
down list. 

Weight By
Choose a column from the Weight By drop-down list to perform weighted averaging. 
With weighted averaging, MapInfo adjusts the calculation of averages so that the 
values from each selected object are weighted more or less heavily. Thus, the Weight 
By column gives some of the selected objects more impact, or "weight" than others. 

For example, your table may contain two numeric columns: a median income column, 
med_inc, and a net population column, net_pop. When you combine two regions in 
this table, you probably want to use the Average option to calculate the average of the 
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median income values. Thus, if one region has a med_inc value of $30,000, and 
another region has a med_inc value of $36,000, and you combine the two regions, the 
resultant region might have a med_inc value of $33,000. 

However, if one of the regions has a larger population than the other region, you 
probably want the larger region's med_inc value to be weighted more heavily when 
MapInfo calculates the average median income. In the Data Aggregation dialog, 
perform these steps: 

1. Choose the med_inc column from the list in the upper part of the dialog. 

2. Choose Average. MapInfo averages the med_inc values when combining 
objects. 

3. Choose the net_pop column from the Weight By drop-down list. MapInfo 
weights the average median income calculations. Thus, objects with large 
net_pop values affect the median income averaging more than objects with 
small net_pop values. 

If you are combining closed objects, the Weight By drop-down list contains a special 
option: Area. If you choose Area from the Weight By drop-down list, MapInfo 
weights the average calculations according to the relative geographic areas of the 
regions to be combined. 

If you are combining linear objects, do not choose Area as the Weight By option. 
Linear objects have no width, thus they have no area. 

To choose standard (non-weighted) averaging, choose "none" from the Weight By 
drop-down list. 

The Weight By control becomes available when you select the Average option. The 
Weight By control is not available if the target object is in a different table than the 
selected objects. 

No Data 
The use of the No Data checkbox depends on whether you have specified a map 
editing target. 

If you have not specified a target, check the No Data checkbox to store blank values 
in all columns of the new row.

 If you have specified a target, check No Data to leave all column values of the target 
object unchanged. 
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DBMS Enhancements

Making a New Connection Using the Open Table Dialog
Use the Open Table dialog to select a table on a remote server.

1. Choose File > Open Table.

2. Click the New Connection button  to display the Open DBMS Connection dialog 

to make a connection.  

Open DBMS Connection Dialog

Opening a DBMS Table from the Open Table Dialog 
If you have established a DBMS connection, you can now choose the connection from 
the Files of Type drop-down list in the Open Table dialog. When you do so, DBMS 
specific options display in the File Open dialog:

For this BETA release:

• Do not open DBMS tables through the DBMS toolbar.Access Remote tables 
through File > Open.

• There are known issues when accessing SQL Server tables live, please access 
SQL Server tables linked.

Connection Type Lists the available driver types: ODBC and/or Oracle. If only one 
driver type is available the control is disabled.  

Connections Lists all open connections.  

New... button Choose to open a new connection. 

Owner Displays the owner list for the selected connection. This option is 
not available if the connection does not support owners. Only 
tables belonging to the selected user display in the table list.

Filter Tables... Displays the Filter Tables dialog. Use this dialog to filter system 
tables, views, synonyms/alias or regular tables. 

Database Displays the name of the database corresponding to the selected 
connection.

Table Lists the tables corresponding to the current connection/owner 
selections. 
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• 0 records display when downloading a table from Oracle or IUS using 
MapInfo drivers on an XP machine.

Close DBMS Connection 
Close one or more DBMS connections using the Close DBMS dialog.

• Choose File > Close DBMS Connection. The Close DBMS dialog displays.

Close DBMS Connection Dialog

Open DBMS Table Options

Conflicts Detection For DBMS Live Access
Because the records in a linked table are from a remote database, it is possible that 
other users may have changed or deleted them on the remote database since the table 

Connections List all open connections, both ODBC and Oracle. 

OK Exit and close the selected connection(s). 

Cancel Exit and close no connections.

MapInfo tab File location Displays name and path of the.tab file that will be created. 
Enter a filename or click the Browse button to display the Save 
As dialog and choose a filename.

Browse (...) Displays the Save As dialog: choose a MapInfo.tab file location. 

Standard/Expert Mode Use Standard Mode to filter columns and rows using the 
corresponding buttons. Use Expert Mode to edit a SQL 
statement. 

Column Filter Displays the Column Picker dialog.

Row Filter Displays the Row Picker dialog.

SQL View Displays the Enter SQL Query dialog.

Linked
Live
Cache 

Cache: The cache button is enabled if the Live option is 
selected.If Cache is checked, MapInfo will store the database 
objects from the initial or current mapview in memory. This 
speeds up subsequent operations. If Cache is unchecked, the 
objects are displayed but not stored in memory. This uses less 
memory but subsequent operations must read the data from 
the database each time they execute.

Back button Takes user back to the Open Table dialog, where the same 
connection/owner/table should be selected. This button is not 
available when in expert mode.

OK button Initiates the opening of the selected DBMS table.
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was downloaded into MapInfo Professional. As a result, conflicts may exist between 
the data residing on the remote database and the new data to be uploaded to the 
remote database.

When saving a linked table, if MapInfo finds conflicts between the data on the remote 
database and any records in the linked table since it was downloaded, the Resolve 
Conflicts dialog displays. Use this dialog to resolve these conflicts. 

The conflict resolution dialog will appear once for each conflicting record. At any 
point in this process, you may choose to leave this interactive mode and have the rest 
of the conflicts resolved automatically. You may use all local values or all server 
values.

Resolve Conflicts Dialog

Column Shows the name of the column in the record that has data which is in 
conflict and needs to be resolved. 
If the column name is too long and does not fit into the list box, a 
truncated representation will be shown instead. 

Original DBMS Displays the original data as it appeared when extracted from the 
database.
If the original data is too long and does not fit into the list box, a 
truncated representation displays.

Current MapInfo Shows the data as it appears in the MapInfo linked table you are 
trying to update. The MapInfo field will be blank if the record has 
been deleted from the MapInfo database. If the data from the MapInfo 
linked table is too long and does not fit into the list box, a truncated 
representation will be shown instead. Its full value can be displayed in 
the MapInfo field, below.

Current DBMS Shows data as it appears in the remote database at the time of the 
update. (This data might have been changed by another user since it 
was downloaded into a MapInfo linked table.)The Current field will 
be blank if the record has been deleted on the remote database, after 
being downloaded into a MapInfo linked table.
If the current data from the remote database is too long and does not 
fit into the list box, a truncated representation will be shown instead. 
Its full value can be displayed in the Current field, below. 
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Current MapInfo: Check this box to update the remote database with the value from the 
MapInfo linked table.
If the current record on the database, or the MapInfo record was 
deleted, then this check box is not available. Instead, you must use the 
MapInfo or Current button, below.

Current DBMS Check this box to retain the current value on the remote database.
If the current record on the database, or the MapInfo record was 
deleted, then this check box is not available. Instead, you must use the 
MapInfo or Current button, below.

MapInfo This button selects all the MapInfo values. If the record you are trying 
to resolve was deleted from the MapInfo database, selecting the 
MapInfo button will delete the record from the remote database. If the 
record you are trying to resolve was deleted from the remote 
database, selecting the MapInfo button will insert the new record into 
the remote database.

DBMS Choose to select all the current DBMS values. If the record you are 
trying to resolve was deleted from the MapInfo database, selecting the 
Current button will ignore the deletion and retain the current record 
in the remote database.If the record you are trying to resolve was 
deleted from the remote database, select the MapInfo to insert the new 
record into the remote database. 

Column Shows the full name of the column highlighted in the list box.

Original DBMS Shows the full value of the original data highlighted in the list box.

Current MapInfo Shows the full value of the MapInfo data highlighted in the list box.

Current DBMS Shows the full value of the current remote database data highlighted 
in the list box.

OK Use the selected values to update of this record.

Stop Commit Terminates the entire update. A second dialog box will display to 
confirm this choice.

Automatic Choose to cause the interactive conflict resolution to end. A dialog 
displays allowing the user to select which of the automatic conflict–
resolution modes will be used for the remainder of this update. One of 
two automatic modes can be selected from the dialog. Accept 
MapInfo values, or the values currently residing on the remote 
database.

Close Edit Linked Table 
Dialog Box

Use the Close Edited Linked Table dialog to close a linked table when 
there are edits pending.

Save Changes to 
MapInfo Table

Save the edits only to the local MapInfo table.
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In this Beta release, you cannot select points when saving a table after a conflict 
detection on XY databases.

Double Stereographic Projection Support
 Double Stereographic Projection number is 31

.

Save Changes to DBMS 
Table

Save edits to DBMS table on the remote database. Edits are also saved 
to the local MapInfo table.

Discard Changes Discard the changes made to the table.

PROJECTIONS Double Stererographic

Datum X

Units X

Origin, Longitude X

Origin, Latitude X

Standard Parallel 1

Standard Parallel 2

Azimuth

Scale Factor X

False Easting X

False Northing X

Range
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Installation
MapInfo Professional 7.0 is compatible with Windows 2000. Based on our 
preliminary testing, your particular configuration may preclude installation. We 
believe this is an InstallShield issue. If you encounter installation problems, please 
report your experience(s) to us.

JPEG2000 
MapInfo Professional 7.0 supports JPEG 2000.

Label Partial Objects
Now you can label partial objects, as well as polylines.  In Map > Layer Control > 
Label dialog, check Label Partial Objects to activate this feature.

Merging a Theme Using Individual Categories from a 
Theme Template
The following checkbox has been added to the Merge Individual Value dialog:

Merge Individual Value Categories

This option is enabled if the current theme is an individual value theme. When the 
template with categories has more categories than the table to which it is being 
applied, those categories are put in the theme, event though the record count on for 
those categories is zero. By default, they will not display in the legend unless the 
display of that category is explicitly turned on in the Customize Legend dialog.

When a table has categories not in the theme template being applied to it, those 
categories are assigned default styles in the same way they would be now when the 
template has fewer styles than the table has categories.

 MGRS Coordinate Strings in the Change View Dialog 
Box
Center a map using Military Grid Reference system coordinate strings to specify the 
center point. This feature is activated when you select Military Grid Reference as the 
Display Coordinates in the Map > Options dialog box or in the Options > Preferences 
> Map Window option.

• Choose Map > Change View. The Change View dialog displays.
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Saving Individual Categories in a Theme Template

North Arrow
North Arrow is a new MapBasic utility added to the Tool Manager. Additionally, it 
can be accessed from the Tools Toolbar. It can add North Arrows of various styles and 
optionally add a Magnetic Declination arrow to a Map or Layout window. Use the 
North Arrow dialog to designate in which corner to position the North Arrow, or use 
the Toolbar button to drag a rectangle and place the North Arrow at the specified 
location.

Accessing North Arrow Using the Tool Manager
NorthArrow.mbx is found in the Tools > Tool Manager. It is not autoloaded by 
default. When the North Arrow is loaded, it displays as Tools > North Arrow menu 
option and as a button on the Tools toolbar.

Using North Arrow 
1. Choose Tools > North Arrow > Draw North Arrow. The North Arrow dialog 

displays.

Center of window Displays and allows you to change coordinates of the 
Map window's center in Military Grid Reference System 
format. If an invalid MGRS string is given, the window 
does not change.

OK Applies the settings.

Cancel Discards settings.
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2. Select arrow style: select a number; the corresponding arrow style displays.

• Foreground brush

• Foreground pen

• Background brush

• Background pen

3. If the active window is a map, these choices display:

• Rotate north arrow to match projection.

• Point north arrow to top of map.

• Insertion Corner: designate the corner in which the arrow will display.

• NorthWest

• NorthEast

• SouthEast

• SouthWest

• Size north arrow to be this percentage of window size:

• Magnetic Declination: Choose to display the Magnetic Declination Dialog.
Beta Documentation 20



MapInfo Professional 7.0 Features and Enhancements 
Magnetic Declination Dialog
Display Magnetic Declination: check to display a Magnetic Declination arrow in 
addition to the north arrow. 

Magnetic Declination: (in degrees from north): Specify the declination angle. Select 
arrow style: Select a number; the corresponding arrow style displays.
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Accessing the North Arrow Tool on the Tools Toolbar
1. Click the North Arrow button to click and drag a rectangle to a map or layout 

window. The North Arrow dialog displays.

2. Select arrow style: Select a number; the corresponding arrow style displays.

• Foreground brush

• Foreground pen

• Background brush

• Background pen

If the active window is a map, these choices display:

• Rotate north arrow to match projection.

• Point north arrow to top of map.

In both map and layout windows, these options display: 

Use aspect ratio of the rectangle you draw: stretch the north arrow to fit the contents 

of the drawn arrow. 

Use aspect ratio of selected north arrow: draw the arrow at original aspect ratio.

Magnetic Declination: Display the Magnetic Declination dialog.

Places Bar  
MapInfo 7.0 includes the Places Bar control in the File Open and Save dialogs. There 
are four MapInfo Professional Places options: Table; Workspaces; MBX; Remote 
Table. Click to display the directory associated with the selected option. Designate 
each directory in Options > Preferences > Directories.

Windows 2000: Choose either MapInfo Places or Standard Places to display Places 
specific to MapInfo or Places specific to Windows 2000.

Preferences

Autoscroll
You can now set the default mode of this feature as a preference. (The default for this 
option is set to ‘on.’) To automatically enable Autoscroll for all newly created map 
and layout windows activate the Autoscroll option. 

• Choose Options > Preferences > Map Window > Autoscroll.

The setting can be overwritten on a per window basis using the Map > Options 
dialog.
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Default Projection
To designate a default table projection for creating new tables, importing MIF, MBI, 
and IMG files and for Choose Projection options in dialogs, use the Default Projection 
Preference > Table Projection option. The setting can be overwritten on a per window 
basis by selecting a different projection using the Choose Projection option.

This feature is not available for the Universal Translator, ArcLink, or Table > Import > 
DXF.

To designate a default table projection:

• Choose Options > Preferences > Map Window Preferences > Table Projection. 
The Choose Projection dialog displays. 

To designate a default MapBasic projection for returning coordinate values using a 
MapBasic window or Update Column, use the Default Projection Preference> Session 
Projection option. Compiled MapBasic applications are not affected by this MapBasic 
session preference.

To designate a default session projection:

• Choose Options > Preferences > Map Window Preferences > Session 
Projection.

The Choose Projection dialog displays.
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Default Styles
Designate defaults for Line, Region, Symbol, and Text styles. Additionally, designate 
highlight controls for selected and target objects.

To designate a Default Style:

• Choose Options > Preferences > Styles. The Styles Preferences dialog 
displays.
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The setting can be overwritten on a per window basis using the Map > Options 
dialog.

Places Bar Directory
MapInfo 7.0 includes a Places Bar in the File Open and Save dialogs. Use this option to 
quickly access the specified directory. There are four MapInfo Professional Places 
options: Table; Workspaces; MBX; Remote Table. Designate each directory in Options 
> Preferences > Directories.

To designate Places Bar directories: 

• Choose Options > Preferences > Directories.   

The Directories Preferences displays. Use the Initial Directories for File Dialogs to 

designate the directory paths.
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Query Find in Front Window Only
Check the ‘Find in Front Window only’ option from the Find Dialog to perform the 
Find Option only in the front window of a Map, Redistrict or Browse window. 

If features are found, they will be marked with a symbol in a Map window. The 
Browser window will be scrolled so that the record appears in the browser view.

Raster Handlers
MapInfo Professional 7.0 includes two raster handlers that support the 5 raster 
formats frequently used by government agencies:

ADRGASRP.rhl supports ADRG and ASRP formats. The default file extension is 
*.gen.

CADRGCIB.rhl supports CADRG, CIB, and NITF. The default extension is *.ntf.

The ADRG format default file extension: *.gen.

The ASRP format default file extension: *.gen.

CADRG format can have any file extension, but the handler does not list *.*; this 
would make filtering useless. Type *.* in the File Open dialog, if necessary.

CIB format can have any file extension, but the handler does not list *.*; this would 
make filtering useless. Type *.* in the File Open dialog, if necessary.

The NITF format default file extension: *.ntf.
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Sample files can be found at http://164.214.2.51/ntb/baseline/software/testfile/
nitfv1.1/scen_1_1.html.

Rotate Objects
Rotate graphical objects, in addition to text and labels. These objects can be rotated: 
lines, polylines, polygon, multipoint, collection, arc, ellipse, rectangle, rounded 
rectangle. An arc, ellipse, rectangle and rounded rectangle are converted to a polyline 
or polygon so the nodes can be rotated. Points cannot be rotated.

To rotate an object:

• Select an object from an editable layer. A rotation handle displays to the right 
and below the lower right corner of the MBR of the selected object.
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Saving Individual Themes
For individual value themes, you now can save the actual categories in a theme 
template. For example: If you choose to build an individual value theme on a table to 
show land usage, you can assign a different region style to each type of land usage 
(commercial, forest, residential, farm land, etc). You may then want to take those 
same assignments and apply them to another table. In previous versions, unless the 
second table had the same categories as the first table upon which the theme was 
built, the categories and their associated region styles would not be the same. If you 
you store the category in the template, it will be associated appropriately when the 
template is applied to that second table.

The following checkbox has been added to the Save Theme to Template dialog:

Save Individual Value Categories  

Enabled only if the current theme is an individual value theme. Allows you to save 
the individual category names with their corresponding styles in the selected theme 

template.
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Shapefile Support
Open Shapefiles directly using the Open File dialog. 

To open a Shapefile:
1. Choose File > Open Table.

2. In the Files of Type drop down, choose Shapefile. The Shapefile Information 
dialog displays.

This information is necessary only when you register a Shapefile the first 
time.
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Shapefile Information Dialog.

Split by Polyline
Split by polyline is enabled when there is an editable target and polyline objects 
selected as cutters. Target objects include points, multipoints, polylines, arcs, regions, 
and other closed objects. The objects selected as cutters must be contiguous, non-
branching polyline objects.

• Choose Objects > Split by Polyline.

File Character Set: Specify the character set used by the file; different 
platforms use different character sets.

Projection The default projection is designated in Options > 
Preferences > Map Window. 

Style Display the appropriate Style dialog.

Save Object Cache Check to create a map file. Leave unchecked to recreate 
the map file each time the file is opened.
Beta Documentation 30



MapInfo Professional 7.0 Features and Enhancements 
TOC Utility
Use the TOC utility to build a seamless table of all the files listed in a TOC file. This 
utility will create one or more seamless tables, grouped by zone and resolution. 

• Choose Tools > TOC Utility. The Table of Contents Utility dialog displays.

TOC Filename and location

Destination directory for Raster Tab files

Destination directory for seamless tables

Choose Browse to display a list of available destinations.
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Undo Nodes During Interactive Polyline/Polygon 
Creation
Use the backspace key to undo the last node when using these tools: add polyline, 
add polygon, custom polyline, custom polygon, polygon search, ruler tool. If only 
one node remains, it will not be deleted.

Universal Translator
The Universal Translator now supports bounded, affined, and affine and bounded 
projections. This ability significantly increases the precision of files brought into 
MapInfo using the Universal Translator.

Translating VPF (Vector Product Format) files is not working in the BETA release. 

User Defined Resolution 
Specify resolution when exporting images to raster formats using Save Window As.

• Choose File > Save Window As. The Save Window As dialog displays.
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Designate Height and Width in pixels. 

Designate Resolution in DPI (dots per inch).

Do not enter invalid (out of range) values for height/width in pixels, an error will 
occur producing an infinite loop.
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For the BETA version, some JPEG 2000 compressed images do not open correctly.

Voronoi Polygons
The Voronoi diagram is a partition of space into cells, each is an area in which the 
contained points are closer to the enclosed site than to any others. Use MapInfo 
Professional 7.0 to generate these polygons from an input set of points.

The Voronoi option is active when there is a current selection which contains at least 
three point objects.  The selection may contain other objects, but these objects will be 
ignored.

To create a Voronoi polygon:

• Choose Objects > Voronoi.  The Voronoi Field Values dialog displays.
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 Destination:  

A list of column names appears in the upper half of the dialog. To select one column 

name from the list, click on that column name. To select a group of column names, 

shift-click. To select or de-select one column at a time, control-click.

Method: 

No Change: Leave the selected columns unchanged.

Blank: Choose Blank to store blank values in the selected column(s). 

To store blank values in all columns, check the No Data checkbox. Only choose the 

Blank option when you want to blank out individual columns.

Value: 

The Value option is a radio button with an associated text edit field.

Choose the Value option to store the value displayed in the edit field in the new row. 

Enter an appropriate value in the field. 

No Change

Leave the selected column unchanged.

No Data: Specify No Data to show blank values in the table of the newly created 

regions.
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Create Cutter statement (new)
Purpose

Use the Create Cutter statement to create a Region object from Polyline object that is then 
suitable to be used for an Objects Split operation.
Given a set of Target objects, and a set of polylines as a selection object, this statement will 
produce a Region object that can be used as a cutter for an Object Split operation, as well 
as a new set of Target objects which may be a subset of the original set of Target objects.

Syntax
Create Cutter Into Target

Description
Before using Create Cutter, one or more Polyline objects must be selected, and an editable 
target must exist. The editing target may have been set by the user choosing Objects > Set 
Target, or it may have been set by the MapBasic statement Set Target. The Polyline objects 
contained in the selection must represent a single, contiguous section. If the Polyline 
selection objects were to be combined into a single object, that object should consist of a 
single section contiguous Polyline, containing no breaks or self intersections.
Each Target object is evaluated to determine if it would be a valid object to Split with the 
Polyline. This is done by determining if the Polyline intersects the MBR of the Target. The 
Polyline need not intersect the Target object itself, as the Target object could be a series of 
islands (e.g., Hawaii), and the Polyline could be used to divide the islands into 2 sets 
without actually intersecting any of the islands. If the MBR of a Target does not intersect 
the Polyline, then that Target will be removed from the Target list.
Given this revised set of Target objects, a cumulative MBR of all of these objects is 
calculated. This represents the overall space to be split. The polyline is then extended, if 
necessary, such that it covers the MBR. This is done by taking the direction of the last 2 
points on each end of the polyline and extending the polyline in that cartesian direction 
until it intersects with the MBR. The extended Polyline should divide the Target space into 
2 portions. One Region object will be created and returned which represents one of these 2 
portions.
This statement will return the revised set of Target objects (still set as the Target), as well as 
this new Region cutter object. This Region object will be inserted into the Target table 
(which has to be an editable table). The original Polyline object(s) will remain, but will no 
longer be selected. The new Region object will now be the selected object.
If the resulting Region object is suitable, then this operation can be immediately followed 
by an Objects Split operation, as appropriate Target objects are set, and a suitable Region 
cutter object is selected.
Note: The cutter object still remains in the target layer. You will have to delete the cutter 
object manually from your editable layer

Create Map Statement (Enhancement)
This enhancement to the Using clause provides an easy method to completely clone 
the structure of a table.

Purpose 
Modifies the structure of a table, making the table mappable. 
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Syntax
Create Map 
For   table 
[ CoordSys... | Using from_table ] 
 
table  is  the name of an open table
CoordSys... is a CoordSys clause

Description
The Create Map statement makes an open table mappable, so that it can be displayed in a 
Map window. 
This statement does not open a new Map window. To open a new Map window, use the 
Map statement
You should not perform a Create Map statement on a table that is already mappable; doing 
so will delete all map objects from the table. If a table already has a map attached, and you 
wish to permanently change the projection of the map, use a Commit Table As statement. 
Alternately, if you wish to temporarily change the projection in which a map is displayed, 
issue a Set Map statement with a CoordSys clause.
The Create Map statement does not work on linked tables. To make a linked table 
mappable, use the Server Create Map statement. 
Specifying the Coordinate System 
Use one of the following two methods to specify the coordinate system: 
Provide the name of an already open mappable table as the from_table portion of the 
Using clause. In this case, the coordinate system used will be identical to that used in the 
from_table. The from_table must be a currently open table, and must be mappable or an 
error will occur.  
Explicitly supply the coordinate system information through a CoordSys clause.

If you omit both the CoordSys clause and the Using clause, the table will use the default 
coordinate system (as set in preferences)

Create Object Statement for Voronoi Polygons
Purpose 

Creates one or more regions by performing a Buffer, Merge, Intersect, Union, Convex Hull, 
or Voronoi operation. 

Syntax
Create Object As { Buffer  |  Union  |  Intersect  |  Merge | ConvexHull | Voronoi } 
  From   fromtable  
[ Into  { Table  intotable  |  Variable  varname  }  ] 
[ Width   bufferwidth  [ Units   unitname  ] ] [Type { Spherical | Cartesian } ] ]
[ Resolution   smoothness   ] 
[ Data   column  =   expression  [ ,  column  =   expression  . . . ]  ] 
[ Group By  { column  |  RowID }  ] 
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Description
The Create Object statement creates one or more new region objects, by performing a 
geographic operation (Buffer, Merge, Intersect, Union or ConvexHull) on one or more 
existing objects. 
The Into clause specifies where results are stored. To store the results in a table, specify 
Into Table. To store the results in an Object variable, specify Into Variable. If you omit the 
Into clause, results are stored in the source table. Note: if you specify a Group By clause to 
perform data aggregation, you must store the results to a table rather than a variable. 
The keyword which follows the As keyword dictates what type of objects will be created. 
Specify Voronoi to create regions that represent the Voronoi solutions of the input points. 
The data values from the original input points can be assigned to the resultant polygon for 
that point by specifying data clauses.

Create Table Statement Enhancements

Combine Objects Using Column Enhancement 

In this version, you will now be able to create a new table as part of the "Combine 
Objects Using Column" functionality. An existing table will be created based on an 
existing table by expanding the Create Table statement to include a Using clause.

Table Creation for DBMS Servers 

The ability to create new tables on DBMS Servers had been included in version 7.0 
from the ODBC Type clause in the Create Table statement. 

Create Table Statement
Purpose 

Creates a new table. 

Syntax
Create Table   table
  { (  column   columntype  [ ,  . . . ] ) | Using from_table }
  [ File   filespec ]
  [ { Type NATIVE  |  
       Type DBF [ CharSet   char_set ]   | 
       Type { Access | ODBC }  Database  database_filespec  [ Version version ]  Table 
tablename   
[ Password  pwd  ]  [ CharSet char_set  ]  
     } ]
  [ Version  version  ]   
table  is the name of the table as you want it to appear in MapInfo.
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column  is the name of a column to create. Column names can be up to 31 characters long, 
and can contain letters, numbers, and the underscore (_) character. Column names cannot 
begin with numbers. 
from_table  is the name of a currently open table.  The from_table must be a base table, and 
must contain column data.  Query tables and raster tables can't be used and will produce 
an error.  The column structure of the new table being created will be identical to this table.

CurrentBorderPen() function (new)
Purpose 

Returns the current border pen style currently in use.

Syntax
CurrentBorderPen( )

Return Value
Pen 

Description
The CurrentBorderPen( ) function returns the current Border Pen style. MapInfo assigns 
the current style to the border of any region objects drawn by the user. If a MapBasic 
program creates an object through a statement such as Create Region, but the statement 
does not include a Pen clause, the object uses the current BorderPen style.
The return value can be assigned to a Pen variable, or may be used as a parameter within a 
statement that takes a Pen setting as a parameter (such as Set Map). 
To extract specific attributes of the Pen style (such as the color), call the StyleAttr( ) 
function.

For more information about Pen settings, see the Pen clause. 

Example  
  Dim p_user_pen As Pen   p_user_pen = CurrentBorderPen( ) 

See Also 
Working with styles (pen, brush, symbol, font)  

CurrentLinePen( ) function (new)
Purpose 

Returns the Pen (line) style currently in use. 

Syntax
CurrentLinePen( )

Return Value
Pen 
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Description
The CurrentLinePen( ) function returns the current Pen style. MapInfo assigns the current 
style to any line or polyline objects drawn by the user. If a MapBasic program creates an 
object through a statement such as Create Line, but the statement does not include a Pen 
clause, the object uses the current Pen style. The return value can be assigned to a Pen 
variable, or may be used as a parameter within a statement that takes a Pen setting as a 
parameter (such as Set Map). 
To extract specific attributes of the Pen style (such as the color), call the StyleAttr( ) 
function.
For more information about Pen settings, see the Pen clause. 

Example  
  Dim p_user_pen As Pen   p_user_pen = CurrentPen( ) 

See Also 
Working with styles (pen, brush, symbol, font)  

CurrentPen( ) function Enhancement
In version 7.0, CurrentPen() will also set the border pen to the same as the line pen. If 
the user just wants the current line pen without re-setting the border pen, they 
should use CurrentLine.

New DBMS function

Server <connection handle> Create Table <table> 

Creates a table on a DBMS server using SQL syntax Pro currently uses for tables, 
making this server independent. This functionality may also be achieved using the 
databases native syntax through the Server Execute statement. 

DocumentWindow Control in MapBasic Dialog
Allows a MapBasic programmer to add a window in a MapBasic dialog that can 
display a map, legend, etc. The DocumentWindow control in a dialog will be used in 
conjunction with the Set Next Document statement in Integrated Mapping.

Control DocumentWindow statement (new)
Purpose 

Part of a Dialog statement; adds a document window control to a dialog which can be 
reparented for integrated mapping. 

Syntax
Control  DocumentWindow
[ Position  x , y ] 
      Width  w ]   [ Height  h ] 
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[ ID  control_ID ] 
[ Disable  ]   [ Hide ]  
x , y  specifies the control's position in dialog units
w  specifies the width of the control in dialog units; default width is 100
h  specifies the height of the control in dialog units; default height is 100
control_ID  is an Integer; cannot be the same as the ID of another control in the dialog
Disable grays out the control initially
Hide initially hides the control

Description
If a Dialog statement includes a Control DocumentWindow clause, the dialog includes a 
document window control that can be reparented using Set Next Document. 

Example 

The following example draws a legend in a dialog:

    Control DocumentWindow
  ID ID_LEGENDWINDOW

      Position 160, 20
      Width 120 Height 150

The dialog handler will need to reparent the window. Here's an example:

Sub DialogHandler
  OnError Goto HandleError
  Dim iHwnd As Integer
  Alter Control ID_LEGENDWINDOW Enable Show
  ' draw the legend
  iHwnd = ReadControlValue(ID_LEGENDWINDOW)
  Set Next Document Parent iHwnd Style WIN_STYLE_CHILD
  Create Legend 
  Exit Sub
HandleError:
  Note "DialogHandler: " + Error$()
End Sub 

New GetFolderPath$() function
Purpose

Return the path of a special MapInfo or Windows folder.

Syntax
GetFolderPath$( folder_id )
folder_id is one of the following values
FOLDER_MI_APPDATA
FOLDER_MI_LOCAL_APPDATA
FOLDER_MI_PREFERENCE
FOLDER_MI_COMMON_APPDATA (new to version 7.0)
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FOLDER_APPDATA
FOLDER_LOCAL_APPDATA
FOLDER_COMMON_APPDATA
FOLDER_COMMON_DOCS
FOLDER_MYDOCS
FOLDER_MYPICS

Return Value
String

Description
Given the id of a "special" MapInfo or Windows folder, the GetFolderPath$() function 
returns the path of the folder.  An example of a special Windows folder is the My 
Documents folder.  An example of a special MapInfo folder is the preference folder; the 
default location to which MapInfo write out the preference file.
Note that the location of many of these folders varies between versions of Windows.  They 
can also vary depending on which user is logged in.
Note that ids beginning in FOLDER_MI return the path for MapInfo specific folders.  The 
rest of the ids return the path for Windows folders and correspond to the ids defined for 
WIN32 API function SHGetFolderPath.  The most common of these ids have been defined 
for easy use in MapBasic applications.  Any id valid to SHGetFolderPath will work with 
GetFolderPath$().

Labeling Partial Objects 
Currently, Labeling Partial Segments can be set in MapBasic using the Set Map 
command Layerclause, Labelclause Partial Segments option and the LayerInfo 
function. For MapInfo Professional Version 7.0, there are changes to the Partial 
Segment functionality.

PartialSegments. Controls whether MapInfo labels an object when the object's 
centroid is not in the visible portion of the map.  If you specify PartialSegments On 

(which corresponds to checking the Label Partial Objects check box), MapInfo labels 
the visible portion of the object.  If you specify PartialSegments Off, an object will 
only be labeled if its centroid appears in the Map window. For MapInfo Professional 
7.0, this feature has been expanded to all object types.  For versions prior to 7.0, only 
linear objects where effected.

LayerInfo( ) function

attribute  code LayerInfo( ) Return Value 

LAYER_INFO_LBL_PARTIALSEGS Logical value; TRUE if the Label Partial Objects 
check box is checked for this layer. 
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New LocateFile$() function
Purpose

Return the path to one of MapInfo application data files.

Syntax
LocateFile$( file_id )
file_id is one of the following values

Return Value
String

Description
Given the id of a MapInfo application data file, returns the location where MapInfo found 
that file.  In versions prior to 6.5 these files where, for the most part, installed into the 
progra mdirectory (same directory as mapinfow.exe).  As of 6.5, MapInfo installs these files 
under the user's Application Data directory, but there are several valid locations for these 
files, including the program directory.  MapBasic applications should not assume the 
location of these files, instead LocateFile$() should be used to determine the actual location.

New SessionInfo( ) function
Purpose 

Returns various pieces of information about a running session of MapInfo.

Syntax
SessionInfo( attribute ) 
attribute  is an Integer code indicating which session attribute to query.

LOCATE_PREF_FILE preference file (mapinfow.prf)

LOCATE_DEF_WOR default workspace file (mapinfow.wor)

LOCATE_CLR_FILE color file (mapinfow.clr)

LOCATE_PEN_FILE pen file (mapinfow.pen)

LOCATE_FNT_FILE symbol file (mapinfow.fnt)

LOCATE_ABB_FILE abbreviation file (mapinfow.abb)

LOCATE_PRJ_FILE projection file (mapinfow.prj)

LOCATE_MNU_FILE menu file (mapinfow.mnu)

LOCATE_CUSTSYMB_DIR custom symbol directory (custsymb)

LOCATE_THMTMPLT_DIR theme template directory (thmtmpl)

LOCATE_GRAPH_DIR graph support directory (GraphSupport)
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Return Value
String 

Description
The SessionInfo( ) function returns information about MapInfo's session status. The 
attribute can be any of the codes listed in the table below. The codes are defined in 
MAPBASIC.DEF.  

Error Conditions 
ERR_FCN_ARG_RANGE error generated if an argument is outside of the valid range

Example  
Include "mapbasic.def"
print SessionInfo(SESSION_INFO_COORDSYS_CLAUSE)

Raster Transparency Updates in the Set Window 
Statement
The Set Window statement now accommodates new methods for handling 
transparency in raster (and grid) images. 

Internal Handling for Transparent Raster has been replaced with Use ROP Method to 
Display Transparent Raster. The Transparency Raster Internal option has been 
removed for 7.0. However, this option will be processed without error to allow for 
backwards compatibility with workspaces created in versions prior to 7.0. 

[ Transparency 
[ Raster { Device | ROP } ]
[ Vector { Device | ROP }] ]

Transparency Raster. Determines how transparent pixels should be rendered. 
Selection of Device or ROP is dependent upon your printer driver or export file 
format. Sometimes the selection is made on a trial basis. You need to see which option 
produces the best output for you.

attribute  code SystemInfo( ) Return Value 

SESSION_INFO_COORDSYS_CLAUS
E

String result, indicates a session's 
CoordSys clause.

SESSION_INFO_DISTANCE_UNITS String result, indicates  a session's 
distance units.

SESSION_INFO_AREA_UNITS String result, indicates a session's area 
units.

SESSION_INFO_PAPER_UNITS String result, indicates a session's 
paper units.
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Transparency Raster ROP.  Corresponds to the "Use ROP Method to Display 
Transparent Raster" option being enabled in the user interface (Preferences > Output, 
File > Print > Advanced button  and File > Save Window As > Advanced button). 
When the ROP method is selected, the transparent image is rendered using a raster 
operation (ROP) to handle the transparent pixels. This method is used to draw 
transparent (non-translucent) images on-screen. This method does not always work 
well when printing. Some print drivers do handle the ROP method correctly though. 
You will need to determine if your particular print driver handles ROPs correctly. 
When exporting using Save Window As, it can be beneficial to use this option if the 
output format is a metafile (EMF or WMF). Using the ROP method allows any 
underlying data to be rendered in the original form. For example, vector data that is 
under transparent pixels will not be rasterized. In metafiles, using ROP method will 
not draw any data in the areas of the raster pixels, allowing the background to be truly 
transparent.

Transparency Raster Device. Corresponds to the "Use ROP Method to Display 
Transparent Raster" option disabled in the user interface (i.e. Preferences > Output, 
File > Print > Advanced button and File > Save Window As > Advanced button). This 
option rasterizes any data contained within the transparent pixel areas. It also fills in 
transparent pixels with the appropriate color values depending upon what is 
underneath the raster image. If exporting to a metafile and there is no data under 
transparent pixels, they will be converted to white pixels.

Transparency Vector Internal. Perform special handling when outputting  
transparent fill patterns or transparent bitmap symbols. 

Transparency Vector Device. Turns off special handling when outputting  transparent 
fill patterns or transparent bitmap symbols. This may cause some problems with the 
generated output. 

ReadControlValue() function Additional Types
DocumentWindow:

Control type: ReadControlValue( ) Return Value 

DocumentWindow Integer, representing the HWND for the window control. This 
HWND should be passed as the parent window handle in the Set Next Document 
Parent statement.
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Rotating Objects
An object can also be rotated using MapBasic by using the new functions Rotate( ) 
and RotateAtPoint( ).

Rotate( ) function
Purpose: 

Allows an object to be rotated about the rotation anchor point.

Syntax:
Rotate(object, angle)

Return Value:
A rotated object.
object represents an object that can be rotated. This may not be a text object. To rotate text 
objects, Alter Object OBJ_GEO_TEXTANGLE should be used. Rotate() and 
RotateAtPoint() do not rotate text objects. This source object is not altered.
angle is a float value that represents the angle (in degrees) to rotate the object.
If an arc, ellipse, rectangle or round rectangle is rotated, the resultant object will be 
converted to a polyline/polygon so that the nodes can be rotated.

RotateAtPoint( ) function
Purpose: 

Rotates an object around a specified anchor point.

Syntax:
RotateAtPoint(object, angle, anchor_point_object)

Return Value:
A rotated object.
object represents an object that can be rotated. This may not be a text object. To rotate text 
objects, Alter Object OBJ_GEO_TEXTANGLE should be used. Rotate() and 
RotateAtPoint() do not rotate text objects. This source object is not altered.
angle is a float value that represents the angle (in degrees) to rotate the object.
anchor_point_object is an object representing the anchor point which the object nodes are 
rotated about.
If an arc, ellipse, rectangle or round rectangle is rotated, the resultant object will be 
converted to a polyline/polygon so that the nodes can be rotated.

Server Create Table statement (new)
Purpose

 Create a new table on a specified remote database.

 Sytax
Server ConnectionNumber Create Table TableName(ColumnName ColumnType [,…]) 
          [KeyColumn ColumnName]
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          [ObjectColumn ColumnName]
          [StyleColumn ColumnName]
          [CoordSys... ]
ConnectionNumber is an integer value that identifies the specifc connection to a database.
TableName is the name of the table as you want to appear in database. 
ColumnName is the name of a column to create. Column names can be up to 31 characters 
long, and can contain letters, numbers, and the underscore(_) character. Column names can 
not begin with numbers. 
ColumnType is the data type associated with the column.
KeyColumn clause specifies key column of the table. 
ObjectColumn clause specifies spatial geometry/object column of the table.
StyleColumn clause specifies the Per Row Style column which allows the use of different 
object styles for each row on the table.
CoordSys... clause specifies the coordinate system and projection to be used. 

Description
The Server Create Table statement create a new empty table on the given database up to 
250 columns.
The length of TableName varies with databases. It is recomended to use 14 or fewer 
charracters for a table name in oerder to work correctly for all databases although the 
statement will  limit the length of the tablename to maximum 31characters. 
ColumnType uses the same data types defined and provided  in Create Table Statement. 
Some types may be converted to the database-supported types accordingly once the table 
is created on the database.
 If the optional KeyColumn clause is specified, an unique index will be created on this 
column. It is recommended to specify this clause and is also needed for MI Pro to open it 
alive.
 The optional ObjectColumn clause indicate the user want to create a table with spatial 
geometry/object column. If it is specified, an spatial index will also be created on this 
column. However, if the server does not have the ability to handle spatial geometry/object, 
the table will not be created.  If the server is SQL Server with SpatialWare, the table is also 
sptialized once the table is created. If the Server is Oracle Spatial, spatial metadata is also 
updated once the table is created. 
The optional CoordSys... clause becomes mandatory only if the table is created with spatial 
object/geometry on Oracle Spatial(Oracle8i or later with spatial option).  If the server is 
Oracle9i, a default datum, World Geodetic System 1984(WGS 84), will be signed to the Lat/Long 
coordinate system if the user provides it as Lat/Long, but does not specify the datum because a 
datum is required by Oracle9i if the coordinate system is Lat/Long. The Coordinate System must 
also be the same as the one specified in Server Create Map Statement when making it 
mappable.  For other DBMS, this clause has no effect on table creation.
The supported databases include Oracle, SQL Server, IDS, and Microsoft Access. However, 
to create a table with spatial geometry/object, SpatialWare/Blade is required for SQL 
Server and IDS, and  spatial option for Oracle.
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Examples
The following examples shows how to create a table named ALLTYPES, containing 7 
columns which cover all the data types supported by MI Pro, plus Key, SpatialObject, and 
Style columns, a total 10 columns.
For SQL Server with SpatialWare or IDS with SpatialWare Blade:

dim hodbc as integer
hodbc = server_connect("ODBC", "dlg=1")
Server hodbc Create Table ALLTYPES( Field1 char(10),Field2 

integer,Field3 smallint,Field4 float,Field5 decimal(10,4),Field6 
date,Field7 logical)
   KeyColumn SW_MEMBER
  ObjectColumn  SW_GEOMETRY
   StyleColumn    MI_STYLE
For Oracle Spatial:

dim hodbc as integer
hodbc = server_connect("ORAINET", 

"SRVR=cygnus;UID=mipro;PWD=mipro")
Server hodbc Create Table ALLTYPES( Field1 char(10),Field2 

integer,Field3 smallint,Field4 float,Field5 decimal(10,4),Field6 
date,Field7 logical)
   KeyColumn MI_PRINX
  ObjectColumnGEOLOC
   StyleColumnMI_STYLE
  CoordsysEarth Projection 1, 0

  See also
Create Table, Server Create Map .

Beta Issues with Server Create Table
1. Cannot insert date format into table created with the Server Create Table 

Function on Oracle XY databases

2. MapInfo will crash when inserting records into a LIVE table that is created 
with the Server Create Table Function on Oracle databases

3. Primary Key Column not created correctly on databases that do not support 
autoincrimention when using the Server Create Table Function

4. Cannot insert objects into an Oracle table that was created using the Server 
Create Table Function without manually making the table mappable and 
entering the correct Projection that was inserted into the 
USER_SDO_GEOM_METADATA.
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Set Style statement (New)
Purpose 

Resets the current Pen, Brush, Symbol or Font style. 

Syntax
Set Style { Brush ...            |    Font ...              |     Pen ...         |   BorderPen…    | LinePen…        
|  Symbol ...     }
Brush clause specifies a fill style 
Font clause specifies a text style
Pen clause specifies a line style                        
BorderPen takes a Pen clause which specifies a border line style 
LinePen  takes a Pen clause which specifies a line style                
Symbol clause specifies a point style

Description
The Set Style statement resets the Pen, Brush, Symbol or Font style currently in use. 
The Pen clause sets both the line and border pen. To set them individually, use the LinePen 
clause to set the line and the BorderPen clause to set the border.
When the user draws a new graphical object to a Map or Layout window, MapInfo creates 
the object using whatever Font, Pen, Brush, and/or Symbol styles are currently in use. 
For more information about Pen, Brush, Symbol, and Font parameters, see the discussions 
of the Pen, Brush, Font and Symbol clauses.

Example of Brush, Symbol and Font
Include "mapbasic.def"
Set Style Brush MakeBrush(64, CYAN, BLUE)
Set Style Symbol MakeSymbol( 9, BLUE, 14)
Set Style Font MakeFont("Helv", 1, 14, BLACK,WHITE)

Example of Pen
In this example the line pen is red and the border pen is red.
Include "mapbasic.def"
Set Style Pen MakePen(3, 9, RED) 

Example of LinePen and BorderPen

In this example the line pen is red and the border pen is green.

Include "mapbasic.def"
Set Style LinePen MakePen(6, 77, RED)
Set Style BorderPen MakePen(6, 77, GREEN) 
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User Defined Resolution and JPEG 2000 support
Additions to the Save Window command allows users to width/height using pixels 
and the resolution (DPI) when exporting images to raster formats using Save 
Window As.  Also, The Resolution setting will allow the Save Window command to 
support a new format - JPEG 2000

Save  Window  window_id  
As  filespec  
Type  filetype  
[ Width  image_width   [ Units paper_units ]  ] 
[ Height  image_height [ Units paper_units ]  ] 

      [ RESOLUTION output_dpi ]
[ Copyright notice   [ Font ... ]  ] 

window_id  is an Integer Window ID representing a Map, Layout, Graph, Legend, 
Statistics, Info, or Ruler window; to obtain a window ID, call a function such as 
FrontWindow( ) or WindowID( )

filespec is a String representing the name of the file to create

filetype  is a String representing a file format: 

• BMP specifies Bitmap format; 

• EMF specifies Windows Enhanced Metafile format.

• J2K specifies JPEG 2000 format;

• JPEG specifies JPEG format;

• PNG specifies Portable Network Graphics format;

• PSD specifies Photoshop 3.0 format; 

• TIFF specifies TIFF format;

• TIFFCMYK specifies TIFF CMYK format;

• WMF specifies Windows Metafile format; 

image_width is a number that specifies the desired image width

image_height  is a number that specifies the desired image height 

output_dpi is a number that specifies the output resolution in DPI (dots per inch)

paper_units  is a string representing a paper unit name (e.g. "cm" for centimeters)

notice is a string that represents a copyright notice; it will appear at the bottom of the 
image

The Font clause specifies a text style
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Final Release Information
While not included in this Beta version, we plan to include the following in the 
shipping version of MapInfo Professional 7.0:

• Updated reporting engine, Crystal Reports 8.5 – With Crystal 8.5 a new set of 
functionality will be provided. Some of the new functions are: Microsoft 
Access back end database system, publish to the html, Export to XML and 
PDF, OLE 2 embedding and much more

• Support for import and export of GML v2 file format

• Smart Update: an easy way to check for product upgrades

• Designed for Microsoft Windows XP, including XP Professional and XP Home

• Certified for Microsoft  Windows 2000

• Support for Windows 98 SR2 and NT 4.0 SP 6 
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